Tuesday, October 15, 2019

Tech Tips
Got a favorite tip to submit, or a question you’d like to see answered? Write to support@comicbase.com
 

Recent Tips:

More Tips...


 

ComicBase Tip:

Moving Your Data from ComicBase Express to ComicBase Professional or Archive Editions

(Instruction Updated for ComicBase 14)

 

Let’s say you’ve been using ComicBase Express (or FREE) and you’ve decided to move into the big leagues with ComicBase Professional or Archive Edition. Normally, moving over your old data is just a matter of launching the new program, then using File > Open to open your old database (which is normally stored in your My Documents folder, under a folder (ComicBase FREE or ComicBase Express) named after the edition fo the program you’d been using. So far, so good.

The problem comes when you download your first update. Since both the Professional and Express Editions contains literally hundreds of thousands of artist, writer, storyline, and other credits that weren’t part of your ComicBase FREE or Express database, it’s going to take some time to get all those loaded in. Moreover, it’s likely that the update will have to stop, compact, and be restarted a few times due to the sheer number of changes causing it to temporarily grow to the 2 GB Windows file size limit, after which it can’t process any more changes until it’s compacted (either automatically, or from File > File Tools > Compact & Verify).

A slightly less straightforward, but far faster way of doing the upgrade is to export your old data out of your ComicBase FREE or Express database, then load it into the database that’s part of your new ComicBase Express or Archive Edition, which already has those credits filled in.

Specifically, do the following:

  1. Launch your ComicBase Professional or Archive Edition
  2. File > Open your old FREE or Express database

    (By default, this will be called “ComicBase Database” and located in either your:
    <My Documents>\Human Computing\ComicBase FREE folder, or your:
    <My Documents>\Human Computing\ComicBase [Atlas] Express folder)

    Before continuing, do a quick check over the database to make sure you’ve opened the right one.
  3. File > Export your data to a text file.

    Call this "Exported Data" and save it on your deskop. When choosing the fields to export, you generally would choose just the Comic Title, Issue, Cost, Condition, and Notes fields, unless you’ve entered lots of custom data in other fields that isn’t going to already be in the new ComicBase database.

    Make sure to also check the “Export only Issues in Stock” option at the bottom of the Export dialog. Checking “Include Field Titles” will also help you match up your data later on.
  4. Now File > Open the ComicBase Database that came as part of your ComicBase Pro/Archive Edition.

    This will be in your:
    <My Documents>\Human Computing\ComicBase Databases folder
  5. Use Internet > Check for Updates and make sure you update it with all the latest comic data and pricing.
  6. Finally, File > Import your old data from the "Exported Data" file on your desktop.
    Make sure to match up the fields in exactly the same order as they were exported (use the preview window at the right to check).

    If you used the “Include Field Titles” option suggested above, make sure to skip past the field headers by setting the “Lines to Skip at Beginning” to 1.

As you do the import, you may be prompted if one of your old database’s titles doesn’t match up with a known title in ComicBase. This can happen if a name has changed, or if you’ve created your own titles which don’t match any titles in ComicBase.